On Mon, Apr 05, 2004 at 04:11:32PM -0400, Kendall Clark wrote: > I put in a bit of an argument near the end for changing the format of > _q_exports from a list of strings to a list of strings and optional > dictionaries (which I suspect can be implemented in a way that breaks > no existing code). An interesting idea. A dict is a bit of overkill since I don't think it should have more than one entry. Perhaps a tuple: _q_exports = ["foo", "bar", ("rdf-model", rdf_model), "baz"] Alternatively, we could have it be purely a rename: _q_exports = ["foo", "bar", ("rdf-model", "rdf_model"), "baz"] 'rdf_model' would then be looked up the normal way (e.g. it could be a package or module). Another advantage is that you can keep _q_exports at the top of the module. I'm not sure if I like it better than the direct function reference version though. Neil