My view is that decorator-notation should not be used for any purpose if you would not, in pre-decorator-notation days, have considered doing the equivalent operation. Using a decorator for classmethod or staticmethod seems fine, but I doubt if anyone here would find this pattern compelling: def myfunc(request): ... myfunc = with_request(myfunc) In Quixote 2, the only thing you need to do, if you like passing the request around, is to override the _q_ methods on your Directory class. It doesn't require any special notation. On Jan 3, 2005, at 8:58 AM, Jason Sibre wrote: > Hmmm... I kinda like that approach. > >> Even better - call it "with_request" instead of "published", and >> combine it with a real "published" decorator that had been being >> discussed a week ago: >> >> @published @with_request >> def myfunc(request): >> ... >> >> Oleg. > > _______________________________________________ > Quixote-users mailing list > Quixote-users@mems-exchange.org > http://mail.mems-exchange.org/mailman/listinfo/quixote-users